Scheduled for December 17, 2025 at 8:00 AM – 8:31 AM
Affects
Genio Notes
Under maintenance from 8:00 AM to 8:31 AM
Login
Under maintenance from 8:00 AM to 8:31 AM
Event Uploading / Downloading
Under maintenance from 8:00 AM to 8:31 AM
Event Sharing / Send A Copy / Collections
Under maintenance from 8:00 AM to 8:31 AM
Tasks
Under maintenance from 8:00 AM to 8:31 AM
Single Sign On
Under maintenance from 8:00 AM to 8:31 AM
Updates
Completed
December 17, 2025 at 8:31 AM
Completed
December 17, 2025 at 8:31 AM
Maintenance has been completed successfully, and access to our applications has now been restored for all users.
Update
December 17, 2025 at 8:24 AM
Update
December 17, 2025 at 8:24 AM
Our maintenance has completed and we're re-introducing traffic to the applications.
In progress
December 17, 2025 at 8:02 AM
In progress
December 17, 2025 at 8:02 AM
Maintenance is now in progress.
Planned
December 17, 2025 at 8:00 AM
Planned
December 17, 2025 at 8:00 AM
Genio Notes & Present will be offline from 8AM to 9AM GMT while we carry out essential database maintenance.
Customers already logged into Genio Notes will continue to be able to record events and create notes. These will sync with the cloud automatically once our change has completed. Transcription, Captions, Image Search, etc. will be unavailable during this change.
Genio Present will be unavailable during the change.
Customers not yet logged into Genio will be unable to do so during this time.